Installing libstdc++-libc6.2-2.so.3 on Ubuntu Hardy Heron (amd64)
I ran into a problem trying to install Websphere Commerce Professional 5.6.1 on Ubuntu it kept complaining about a missing library:

error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

So I started searching the net, and after quite a while I came across someone that had a similar problem when trying to do this under the amd64 arch. There doesn’t seem to be a native amd64 libstdc++-libc6.2-2.so.3 library available, and apparently building the library fails, so how can we get around this?

Well after finding this post on the Ubuntu forums that seems to work for me too!
So you can just

1. Download the .deb
2. Install the .deb overriding the arch

sudo dpkg --force-architecture -i libstdc++2.10-glibc2.2_2.95.4-24_i386.deb

3. BUT, this is generally not a good idea as someone pointed out to me, it works for this situation but you run the risk of overwriting some real amd64 libraries. It just so happens that this package only has 2 files in it, so it works.
4. A better solution would be to extract the files manually into /usr/lib32
5. You’re good to go!
Source via Jason Blog

Feedbacks: We appreciate your feedbacks and suggestions about our website bala@techgyaan.org
Check out . Follow @techgyaan